Problem with source labels

Carter Bullard carter at
Thu Dec 5 15:03:53 EST 2013

Hey David,
Its not the client code, they will do the right thing if argus identifies the format of the source id correctly.
Do you have an /etc/argus.conf file that defines the source id ?
If you run argus this way, does it get better ?

   argus -Xe \”1234\” -w - | ra -s +srcid

The X tells argus not to parse the /etc/argus.conf file.


On Dec 4, 2013, at 5:02 PM, David <lists at> wrote:

> Hi,
> I am just trying out a new argus install, using argus and
> clients
> To reproduce my problem I run argus like so:
> argus -e \"1234\" -w - | ra -s +srcid
> This always seems to print the srcid value as an IP address, regardless
> of what source ID is set.  This is the same whether the source ID is
> numeric (e.g. 1234) or alphanumeric (A123).
> I have tried multiple ways of escaping the quotes but I don't think this
> is the problem.  To verify the argument was being parsed I edited the
> ArgusParseSourceID function and validated that it calls setArgusID with
> a type of ARGUS_TYPE_STRING.  A debug print of optarg in this function
> shows the correct 4 characters.
> Is there something unusual happening with the client code, or am I doing
> something wrong?
> David

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 7322 bytes
Desc: not available
URL: <>

More information about the argus mailing list