[ARGUS] small fixes for ragraph

Carter Bullard carter at qosient.com
Tue Jun 9 09:47:19 EDT 2020

Hey Duc Le,
You’ve modified the line argument syntax in a few places for calling rrdtool.
What version of rrdtool are you using ??  Has it changed recently ???

ragraph uses rabins.1 to process its data, so any options are the same as those for rabins.1
The “-m aggregation object(s)” allows you to control how data is aggregated.
Checkout ‘man rabins’ and also racluster.1 as it also uses this approach.


> On Jun 6, 2020, at 6:19 PM, Le Duc <leloiboi1 at gmail.com> wrote:
> Hi,
> Recently I tried ragraph and encountered some errors. I searched around and tried this fix: https://gist.github.com/Tormyst/03f9b15156de86b9e5ee524e7f6f8c6c <https://gist.github.com/Tormyst/03f9b15156de86b9e5ee524e7f6f8c6c>. But it does not solve all the problems, so I changed it a bit more and I think I got a working version now (attached). Diff is also attached.
> Also, I want to ask about option "-m" used in ragraph (example here <>), what does it do?
> Regards,
> Duc Le
> <diff.txt><ragraph>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://pairlist1.pair.net/pipermail/argus/attachments/20200609/90258102/attachment.html>

More information about the argus mailing list